Raspberry Pi il mio primo linux embedded

Gli argomenti che non trovano spazio nelle altre sezione devono essere inseriti qui. Sarà poi lo staff a spostare la discussione nella sezione più adatta.
cecco
Messaggi: 6
Iscritto il: 14/01/2014, 21:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da cecco » 14/01/2014, 21:19

ciao a tutti, sto facendo il percorso del libro e fin ora in qualche modo sono riuscito ad andare avanti nonostante che molti argomenti sono per me nuovi.

mi sono bloccato sulla parte in cui devo inserire il listato in phpMyAdmin. lo carico come descritto nel libro ma mi restituisce un errore 1046.
è successo già a qualcuno? mi piacerebbe tanto finire il libro ma sono 2 giorni che sto facendo tentativi per cercare di risolvere, ho cercato anche in siti e forum che trattano dell'argomento ma senza risultato.

se avete qualche suggerimento o esperienza vi chiedo per favore di aiutarmi.

lo so, sicuramente sono io che sono incapace.... :oops:

alebambi81
Messaggi: 3
Iscritto il: 11/01/2014, 21:24
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da alebambi81 » 14/01/2014, 22:50

Ciao,
io ho scaricato il listato dalla pagina web del libro e l'ho corretto in quanto non era aggiornato.
Lo trovi qui
https://www.dropbox.com/s/xt09sab2ulc4bnz/RaspiBase.sql
Spero sia quello che ti serviva!

cecco
Messaggi: 6
Iscritto il: 14/01/2014, 21:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da cecco » 15/01/2014, 10:42

il file che mi hai passato dovrebbe essere già corretto?

grazie mille! stasera provo e faccio sapere. :D

alebambi81
Messaggi: 3
Iscritto il: 11/01/2014, 21:24
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da alebambi81 » 15/01/2014, 12:29

Sì sì è corretto, a me lo importa correttamente e crea le tabelle giuste ;)

cecco
Messaggi: 6
Iscritto il: 14/01/2014, 21:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da cecco » 15/01/2014, 14:27

Grazieeee!!!!!!

me l'ha preso! :D

ora speriamo di andare avanti senza difficoltà... :mrgreen:

cecco
Messaggi: 6
Iscritto il: 14/01/2014, 21:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da cecco » 17/01/2014, 12:44

Niente, ci sono di nuovo.
Ho letto che anche voi avete avuto problemi con emoncms.
Dopo aver installato emoncms, aver modificato il file settings.php e tutte le procedure del caso quando mi collego da browser all' IP-Raspy/emoncms mi da pagina bianca con il messaggio: Can't connect to redis database, phpredis is not installed, see readme for redis installation.
ho reinstallato emoncms 2 o 3 volte ma niente.
Voi vi ci siete trovati??

dibelardino
Messaggi: 8
Iscritto il: 30/01/2014, 8:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da dibelardino » 30/01/2014, 8:12

cecco ha scritto:Niente, ci sono di nuovo.
Ho letto che anche voi avete avuto problemi con emoncms.
Dopo aver installato emoncms, aver modificato il file settings.php e tutte le procedure del caso quando mi collego da browser all' IP-Raspy/emoncms mi da pagina bianca con il messaggio: Can't connect to redis database, phpredis is not installed, see readme for redis installation.
ho reinstallato emoncms 2 o 3 volte ma niente.
Voi vi ci siete trovati??

Stesso problema anche per me.
Ho provato a seguire le istruzioni di istallazione di emoncms contenute nel read.me

sudo apt-get install redis-server
sudo pecl install redis

sudo sh -c 'echo "extension=redis.so" > /etc/php5/apache2/conf.d/20-redis.ini'
sudo sh -c 'echo "extension=redis.so" > /etc/php5/cli/conf.d/20-redis.ini'

Ma mi fermo alla seconda istruzione in quanto non riconosce "pecl"

Come hai risolto?
Saluti Marco

cecco
Messaggi: 6
Iscritto il: 14/01/2014, 21:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da cecco » 04/02/2014, 21:01

ciao dibelardino, ho risolto proprio oggi grazie a un'amico.
ho risolto così:

sudo apt-get install php-pear

sudo apt-get install php5-dev

sudo apt-get install libcurl3-openssl-dev

sudo pecl install redis

sudo sh -c 'echo "extension=redis.so" > /etc/php5/apache2/conf.d/20-redis.ini'
sudo sh -c 'echo "extension=redis.so" > /etc/php5/cli/conf.d/20-redis.ini'

fai sapere....

intanto io da vero incapace mi sono fermato all'ultima pagina. non capisco ma non riesco a loggarmi alla paginetta creata. mi da sempre errore login. qualcuno di voi ci si è trovato o ha un consiglio su dove agire??

dibelardino
Messaggi: 8
Iscritto il: 30/01/2014, 8:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da dibelardino » 04/02/2014, 22:43

Se stai usando i files del sito l'id è admin la password è pi.
Altrimenti password admin.
Ciao.

cecco
Messaggi: 6
Iscritto il: 14/01/2014, 21:06
Home_Page: http://

Re: Raspberry Pi il mio primo linux embedded

Messaggio da cecco » 04/02/2014, 23:05

si, credo che dovrei usare utente pi e pass admin ma non funziona, ho provato pure admin admin e non funziona lo stesso.
nella stringa del browser mi viene:

mioip/index.php?error=incorrectLogin

non capisco dove ho toppato.

Rispondi