WiShield non funziona con tutti i Router/A.P. WiFi

Sezione dedicata ai problemi di funzionamento delle scatole di montaggio.
Rispondi
nettonur
Messaggi: 2
Iscritto il: 03/08/2013, 12:53
Home_Page: http://
Compleanno: 29 apr 1958

WiShield non funziona con tutti i Router/A.P. WiFi

Messaggio da nettonur » 07/08/2013, 16:44

Problema
WifiShield (con modulo MRF24WB0MA della Microchip) non funziona con tutti i router/A.P. WiFi con il quale l'ho provato

Configurazione hw/sw
1) ARDUINO UNO R3
2) WiShield
3) IDE 0023 (installato su Win7 64bit)
4) librerie asynclabs-WiShield-v1.3.0-0
5) sketch provato (preso dagli 'examples'): WebServer


Router/A.P. con i quali sono stati fatti i test
a) EDIMAX AR-7084gA Router ADSL
b) NETGEAR Wireless-G Router 54 WGR614
c) DLINK DAP-2360

Note
Chiaramente i Router testati erano dislocati in luoghi diversi con parametri diversi (SSID, Encryption, ecc): per ogni prova sono stati impostati i parametri corretti e opportuni

Esito dei test
a) e' il router 'target'... con il quale sto realizzando un progetto casalingo.. e con questo non funziona in alcun modo...
a.1) disabilitando/abilitando l'encryption
a.2) cambiano porta USB del PC
a.3) cambiando PC
a.4) alimentando ARDUINO direttamente con un alimentatore a 5V
a.5) ponendo ARDUINO+WiShield vicino all' A.P.
a.6) RISULTATO: la connessione all'AP non avviene e il LED del WiShield si accende per 8sec circa, rimane spento per 5sec, si riaccende per 8sec., e cosi via... come se tentasse continuamente invano di connettersi all' A.P.

b) funziona egregiamente
b.1) dopo aver spento e riacceso l'A.P., il WiShield riesce a riprendere la connessione

c) inizialmente ha funzionato... poi l'accesso alla pagine di prove del WebServer era negato mentre al ping il WiShield rispondeva
c.1) NOTA: la distanza tra A.P. e WiShiled era notevole (20/30 metri con vari ostacoli in mezzo)

DOMANDE
Avendo assodato che il WiShield e' stato acquistato per la realizzazione di un progetto casalingo, e che quindi deve funzionare con il router a)....
1) Ci potrebbero essere dei parametri da configurare all'interno dell'A.P. (esempio Canale Wireless?)
2) sono note delle incompatibilita' tra WiShield e dei router particolari?
3) potreste indicarmi eventuali prove da effettuare?

grazie per la pazienza

Rispondi