Problemi con SITEPLAYER

Telecontrolli GSM, via LAN, con Bluetooth, radio
Rispondi
rudylavilla
Messaggi: 1
Iscritto il: 15/04/2010, 10:39
Home_Page: http://

Problemi con SITEPLAYER

Messaggio da rudylavilla »

Ciao a tutti, sto' provando il modulino siteplayer acquistato da voi per l'interfacciamento alla rete di vari tipi di controllori (io al solito lavoro con i PIC).
Il problema e' il seguente, (anzi sono due problemi in realta'):
Primo, il modulo non mi riconosce il DHCP, il mio router e' settato come server dhcp con dei particolari indirizzi fissi (uno dei quali e' riservato al siteplayer), ma non funziona. Se io inserisco nel file di configurazione del siteplayer i parametri "$DHCP on" e a seguire "$InitialIP "192.168.1.10", in teoria il modulo dovrebbe per primo ricevere l'indirizzo dal server dhcp, il quale, riconoscendo l'indirizzo mac del modulino gli dovrebbe assegnare l'indirizzo 192.168.1.7. In realta' non e' cosi', il modulo prende l'indirizzo assegnato dalla variabile nel file di configurazione e me lo trovo sempre a 192.168.1.10.

Secondo, pur avendo aperto la porta 80 sul router , modalita' tcp ed avendola assegnata all'ip del modulo siteplayer, non ho risposta quando lo chiamo dall'esterno. Per i pc in rete interna tutto ok, tutti lo vedono benissimo ma... non esco, ci sono altri parametri nel siteplayer da inserire?

Curiosita', come fa il siteplayer a conoscere l'indirizzo del gateway della mia rete?

Spero qualcuno mi possa aiutare per risolvere questi problemi, grazie in anticipo.

Rispondi