problema temperatura

Sezione dedicata alla stampante 3D realizzata da Futura Elettronica in collaborazione con Elettronica In.
Ulteriori informazioni su http://3dprint.elettronicain.it/
dandao
Messaggi: 36
Iscritto il: 10/07/2013, 11:54
Occupazione: Operaio
Home_Page: http://
Compleanno: 28 lug 1968

Re: problema temperatura

Messaggio da dandao »

Ho messo un video per far capire meglio
https://plus.google.com/113528809531933 ... ZGSWUgR9sL

Ciao

Avatar utente
dp58
Messaggi: 21
Iscritto il: 07/11/2013, 16:21
Cod. abbonamento Elettronica In: 9092B
Occupazione: informatico
Home_Page: http://
Compleanno: 24 apr 1958
Città: Pisa
Prov.: PI
Via: Svezia 14

Re: problema temperatura

Messaggio da dp58 »

Non ho mai visto questo errore e il messaggio non e' molto chiaro.
Io proverei a controllare che il termistore funzioni bene e sia collegato correttamente sul connettore giusto della scheda.
Da controllare i collegamenti elettrici all'estrusore, al piatto riscaldato e all'alimentatore.
Verificherei anche la comunicazione fra PC e scheda stampante:
in Repetier --> Impostazioni stampante --> Connessione --> Baud rate: 250000
(eventualmente confronta la finestra con le istruzioni per la 3Drag http://3dprint.elettronicain.it/2012/09 ... a-3drag/2/

Mi rendo conto che e' un po' poco .... forse ci vuole qualcuno di F.E.
Eventualmente puoi guardare questi post che ho trovato, in cui si parla dell'errore che compare a te:
viewtopic.php?f=67&t=65472
viewtopic.php?f=67&t=65445&p=67246&hili ... off#p67246

http://forum.velleman.eu/viewtopic.php?f=51&t=10897

http://help.printrbot.com/Answers/View/ ... +triggered

http://www.bukobot.com/troubleshooting
dp58

3Drag 1.1
LCD FT1078K
piatto riscaldato opzionale Futura El.

sl45h
Messaggi: 5
Iscritto il: 22/03/2014, 9:12
Home_Page: http://
Località: Udine

Re: problema temperatura

Messaggio da sl45h »

ciao,
l'errore e' un errore di stop molto generico e non credo dipenda dalla temperatura (dice solo che sara' resettata) e si trova nel file "Menu Plans.xlsx" marlin
#define MSG_ERR_STOPPED "Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)" alla riga 136
se ho un attimo di tempo provero' ad indagare da quale funzione viene emesso...
ciao
sl45h
3DRAG v1.1
3DCONTR-DRIVER
3DHEATERPLATE

sl45h
Messaggi: 5
Iscritto il: 22/03/2014, 9:12
Home_Page: http://
Località: Udine

Re: problema temperatura

Messaggio da sl45h »

.... mi correggo, il messaggio, comunque un po' ambiguo, dipende dalla temperatura e dalla lettura della sd sull lcd driver (ma non mi sembra il tuo caso). La funzione Stop() emette il messaggio e viene invocata quando viene registrato un problema di temperatura del piatto, dall estrusore o appunto da un problema con la lettura dalla sd. Io procederei per tentativi sostituendo per primo il sensore del piatto.
Visto che parliamo di temperatura, quest' inverno mi e' capitato che la stampante, una sera, non funzionava piu', motivo? la temperatura ambientale era troppo bassa (sotto i 5 gradi, tengo la stampante in garage) e il software essendo tarato ad una temperatura minima di 5 gradi non le permetteva di partire.....
ciao
sl45h
3DRAG v1.1
3DCONTR-DRIVER
3DHEATERPLATE

dandao
Messaggi: 36
Iscritto il: 10/07/2013, 11:54
Occupazione: Operaio
Home_Page: http://
Compleanno: 28 lug 1968

Re: problema temperatura

Messaggio da dandao »

Intanto grazie per le risposte,
adesso sto stampando il coperchio del controller 3drag in PLA
sono arrivato a 100 layer su 250 e tutto procede bene
Mentre prima stampavo con abs, quindi a temperature più alte sia del piatto che dell'estrusore
vorrà dire qualcosa?

ciao

dandao
Messaggi: 36
Iscritto il: 10/07/2013, 11:54
Occupazione: Operaio
Home_Page: http://
Compleanno: 28 lug 1968

Re: problema temperatura

Messaggio da dandao »

Niente da fare,
la stampante era ferma come se avesse finito
ma in realtà mancano circa 10 mm di materiale

Avatar utente
dp58
Messaggi: 21
Iscritto il: 07/11/2013, 16:21
Cod. abbonamento Elettronica In: 9092B
Occupazione: informatico
Home_Page: http://
Compleanno: 24 apr 1958
Città: Pisa
Prov.: PI
Via: Svezia 14

Re: problema temperatura

Messaggio da dp58 »

E' strano: sembra che in realta' funzioni tutto correttamente per un po', poi improvvisamente il sensore di temperatura smetta di fare il suo lavoro.
Quindi i casi che mi vengono in mente sono due: o l'hot-end o il piatto smettono di riscaldare, oppure il termistore smette di misurare la temperatura.
A naso sarei piu' per la seconda ipotesi: potrebbe esserci un collegamento precario che, a causa degli scossoni della stampante, fa perdere il collegamento fra sensore e controller; il controller non rileva piu' la temperatura e il firmware blocca la stampa per non rovinare l'estrusore.

Ovviamente e' solo un'ipotesi, pero' fossi in te controllerei attentamente le saldature/crimpature fra i sensori e i fili di collegamento e fra i fili e i connettori sulla scheda controller.
Facci sapere. Ciao.
dp58

3Drag 1.1
LCD FT1078K
piatto riscaldato opzionale Futura El.

dandao
Messaggi: 36
Iscritto il: 10/07/2013, 11:54
Occupazione: Operaio
Home_Page: http://
Compleanno: 28 lug 1968

Re: problema temperatura

Messaggio da dandao »

Salve ragazzi,sono stato un poco impegnatoe non ho più usato la stampante,
intanto ho preso un ugello da 0.3 da Futura e un estrusore da 0,35 x filo da 3 da IEC e ho iniziato a fare delle prove:
Prime 3 stampe con ugello da 0,3 e nessun problema e qualità molto migliorata,poi improvvisamente non sono più riuscito a stampare, ho smontato l'estrusore e ho notato dentro una parete di plastica non fusa, allora ho montato l'estrusore della IEC rifatto tutto il cablaggio e sono ripartito
Le prime stampe sono andate bene poi mi e successo due volte lo stesso problema stampa bloccata senza errore, estrusore acceso, piatto acceso e nessuna risposta dalla stampante
Ho dovuto riavviare Repetier e ai primi riavvii non si connetteva nessun dispositivo rilevato, ho dovuto staccare l'USB e resettare la scheda per farlo connettere
Adesso ho fatto 5 stampe senza problemi se non in una stampa ho avuto una perdita di passi 1mm sull'asse x su un pezzo alto 34 mm mi e successo a circa 24 mm
allego 2 foto Immagine Immagine

ciao e Buona Pasqua A tutti

dandao
Messaggi: 36
Iscritto il: 10/07/2013, 11:54
Occupazione: Operaio
Home_Page: http://
Compleanno: 28 lug 1968

Re: problema temperatura

Messaggio da dandao »

Ancora problemi,
per una decina di giorni non ho usato la stampante, poi mi sono arrivati i pezzi per la modifica dell'ass z con barra trp 10,2 e dopo aver sistemato il tutto volevo provarla.
Accendo la stampante e subito noto che la temperatura dell'estrusore e 35° mentre il piatto e 18°, dopo poco mi ricompare il solito errore M9999 Restart che mi costringe a resettare Repetier
Riavvio tutto e l'estrusore segna 0 (a dimenticavo di dire che stavo lavorando con l'estrusore della IEC da 0,35)
Ricontrollo tutti i cablaggi dell'estrusore e non trovo nulla di anomalo, preso dallo sconforto provo a ricollegare l'estrusore originale con il foro da 0,3 e questo segna la tempratura corretta 17°allora lo smonto e lo pulisco per bene perchè l'avevo cambiato che non mi passava piu il materiale. Lo rimonto la temperatura sembra OK ma ABS a 250° non esce metto il PLA arrivo fino a 250 e esce appena, rimonto il foro originale da 0,5 e a 250 esce un poco di materiale e poi si blocca
Non so più cosa fare
Mi procuro un termometro e verifico le temperature
Piatto di stampa impostato a 90° temometro sul vetro da 3mm segna 80°
Estrusore sulla punta impostato a 250 segna 180°
Qualcuno mi puo aiutare a capirci qualcosa?

Grazie

Avatar utente
dp58
Messaggi: 21
Iscritto il: 07/11/2013, 16:21
Cod. abbonamento Elettronica In: 9092B
Occupazione: informatico
Home_Page: http://
Compleanno: 24 apr 1958
Città: Pisa
Prov.: PI
Via: Svezia 14

Re: problema temperatura

Messaggio da dp58 »

L'errore nella temperatura dell'estrusore e' decisamente eccessivo.
180 gradi sono appena sufficienti per fondere il PLA (non sempre), l'ABS non se ne parla neppure.
Infatti, in condizioni normali, quando la temperatura dell'estrusore scende sotto questa soglia, il firmware blocca l'estrusione per non rovinare il motore.

Se la temperatura e' impostata a 250 gradi ma il tuo termometro ne misura solo 180 (dando per scontato che questa misura sia corretta), le possibilita' sono:
- il termistore non e' stato fissato ben a contatto con l'hot-end e quindi non rileva correttamente la temperatura; verificare bloccaggio e pasta termica;
- il valore del termistore non e' 100 Kohm (improbabile);
- la resistenza non e' stata fissata ben a contatto con l'hot-end e quindi non riesce a trasferire tutto il calore che produce; verificare bloccaggio e pasta termica;
- la resistenza non riceve una tensione sufficiente; potrebbero essere i fili troppo sottili o saldati male; potresti tentare di misurare la tensione ai capi della resistenza, quindi vicino all'hot-end, impostando la temperatura al max, in modo da ridurre al minimo l'oscillazione on-off del PWM. Oppure, con le stesse modalita', misurare la corrente in uscita dal mosfet; se non ricordo male, la resistenza e' da 33W, quindi si puo' ricavare la tensione.

Qualcuno "in ascolto" ha qualche altra idea ?
dp58

3Drag 1.1
LCD FT1078K
piatto riscaldato opzionale Futura El.

Rispondi